Thunderbird on desktop

Configure an LDAP account in Thunderbird

You can configure an LDAP account in Thunderbird to look up the shared contacts on the server. Refer the topic import contacts into Thunderbird to save the contacts for offline use. Go through the troubleshooting topic if you face any problem while configuring the account.

  1. Select the Address Book tab
  2. Select the menu File => New => LDAP Directory
  3. On the Directory Server Properties window,
    1. Select the General tab and provide account settings
      • Hostname: Enter Server name URL For example, mail.mithiskyconnect.com
      Don't know your server name? Access the online help to know the server settings required to configure your account. 
      • Base DN: Enter the string dc=addressbook
      • Use secure connection (SSL): Keep the check-box selected
      • Port Number: Keep the port number value 636 as it is
      • Bind DN: Enter the string in the format given below without any space or newline in it mail={user id},dc=addressbookExample : mail=smith@mithiskyconnect.com,dc=addressbook
      Using Mithi SkyConnect trial account? Use the User Id received in the Welcome Mail and Password provided by the Mithi team.
    2. Want to connect to the server without using SSL?Select the Advanced tab,
      • Scope: Choose the Subtree option
      • Serach Filter: Keep the value blank
      • Login Method: Select the Simple option from the list
    3. Click OK to configure the account.

Assign the directory for auto-completion

  1. Go to the menu Tools => Options​
  2. Select the Composition => Addressing tab​
  3. Select the Directory Server box​
  4. Choose the LDAP directory from the list ​
  5. Click OK to continue.

Search contacts on the server

  1. Go to the menu Edit => Search Addresses
  2. You need to provide the password of your account for the first time connection to the server. Choose to save the password in the password bank for future.
  3. On the Advanced Address Book Search window,
    1. Search in : Choose the newly created LDAP Directory account
    2. Search Criteria: Define the serach criteria For example, search addresses whose Display Name contains the character a
    3. Click the Search button to proceed.
    All the matching addresses are listed on the screen. This way you can only search and view the contacts on the server. Each time while composing an email, you need to select the addressbook we have configured and search for a required contact on the server. You can Import Contacts from server into Thunderbird local contacts to avoid searching each time.

Import contacts saved in CSV to Thunderbird

You can import contacts into Thunderbird for offline use. Thunderbird allows various file format to import. This document gives you instructions to import CSV files into Thunderbird.
  1. Select the Address Book tab
  2. From the Tools menu, choose the Import option.
  3. On the Import wizard, choose the Addressbook option to import. Click Next to continue.
  4. Choose the Text file option from the list. Click Next to continue.
  5. Locate .csv or the LDIF/ tab delimited file on your machine which needs to be imported.
  6. Click the Open button to import the selected file.
  7. Match the address book fields with source record data file. Click Ok to finish the import process.
  8. Thunderbird creates an Addressbook with same name as that of the csv file you are importing. Select the addreesbook to view all the imported contacts.

Import contacts saved in VCF to Thunderbird

You can import contacts into Thunderbird for offline use. Thunderbird allows various file format to import. This document gives you instructions to import VCF files into Thunderbird.

  1. Select the Address Book tab
  2. From the Tools menu, choose the Import option.
  3. On the Import wizard, choose the Addressbooks option to import. Click Next to continue.
  4. Choose the vCard file (.vcf) type of file to import. Click Next to continue.
  5. Locate the .vcf file on your machine to be imported. Click the Open button to import the file.
  6. Click the Finish button to complete the import process.
  7. Thunderbird creates an Addressbook with same name as that of the vcf file you are importing. Select the addreesbook to view all the imported contacts.

Export Contacts from Thunderbird

You can export your contact list from Thunderbird to a .csv format file.

  1. Select the Address Book tab
  2. From the Tools menu, choose the Export option.
  3. Save the file with required file type
  4. Give name to the file and save it at required location on your machine.
  5. Thunderbird exports all the contacts and saves in the selected format file.